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Import Digital Globe tiled data (.TIL) with ERDAS IMAGINE 

ERDAS has added support in IMAGINE 2011 for the DigitalGlobe .TIL format. DigitalGlobe often 
delivers images cut into smaller tiles that do not overlap. Often times image files can be 
extremely large in file size. To better handle these large files in 3rd party software, DigitalGlobe’s 
customers have the option to tile the imagery.  An ancillary .TIL text file provides a list of these 
tiles and their relationships. To use these files in georeferencing workflows, they must be 
assembled back into a single original image. The ERDAS IMAGINE importer now allows you to 
select a .TIL file and import all the tiles into a single file. The georeferencing information (RPC) 
is still preserved (see “DigitalGlobe RPC in ERDAS IMAGINE” documentation for RPC 
explanation). Additionally, this support can be used for direct-read scenarios, so the assembled 
tiles can be used directly in workflows without first processing them into a new file. Users can 
type *.TIL in the file chooser to expose this option.  
 
Note: This feature works for both NITF and TIFF tiled files, and the .RPB file must reside in the 
same folder as the imagery tiles for proper georeferencing. 

 

 

 
Fig.1. Importing Tiled Imagery 

.TIL Importer 



  
 
 
 
  

 

 
 

 
To import a DigitalGlobe .TIL file in ERDAS IMAGINE, follow the steps below. 

1. Open ERDAS IMAGINE and click on the Manage Data tab 

 
 

 Fig.2. Import Data 

 

2. Click Import Data 

3. In the Import Dialog, change the Type to DigitalGlobe TIL 

4. For the Input File, navigate to the directory where your DigitalGlobe imagery is stored 
and select the .TIL file  (see fig.3) 

5. Change the Output File name and directory as desired and click OK. 



  
 
 
 
  

 

 
                            Fig.3. Import DigitalGlobe TIL 

 
Note: By default, the import process will create an .img file, but you have the option of writing 
the .TIL file directly to any of the formats shown in the figure 4.  
 

                      
 
                        Fig.4. Ouput .img file 



  
 
 
 
  

 

Create an Ortho from existing RPC model 

1. When the import process is finished, open the new file in the Viewer. File > Open > 
Raster Layer 

 
2. Click on the Multispectral tab and click the Transform and Ortho drop down menu and 

select Ortho Using Existing Model. (see below) 

 

Fig.5. Select Ortho Using Existing Model 

 

 

 

 

 

 



  
 
 
 
  

 

In the Resample dialog, note that the Current Geo Model is RFunctions, meaning the import 
process preserved the RPC information and we can now create an ortho.  

Note the Elevation Source is set to Elevation Library by default. The Elevation Library 
Manager provides a method to collect and manage your elevation source files, including 
Digital Elevation Model data (DEM), as well as Digital Terrain Elevation Data (DTED) use by 
the U.S. National Geospatial-Intelligence Agency.  

3. Name the Output file and click OK 

 

 
Fig.6. Resample  

4. Once the orthorectification process is complete, dismiss the process window by clicking 
Dismiss and open the new Ortho Image in the viewer. 

5. On the main menu select File > Open > Raster Layer and navigate to the folder with your 
new Orthorectified Image 



  
 
 
 
  

 

Switching Band Combinations with WorldView-2 

WorldView-2 is the first sensor of its kind to offer 8 multispectral imaging bands. Up until the 
launch of WorldView-2 most high resolution satellites imaged with four (4) multispectral bands 
(Blue, Green, Red and Near-Infrared) or less. WorldView-2 not only images with those bands 
mentioned but also employs the Coastal Blue Band, Yellow Band, Red-Edge Band and Near-
Infrared 2 Band. This allows for more of the visible spectrum to be absorbed by the sensor 
ultimately providing more information within the pixels of the image. In IMAGINE 2011, ERDAS 
has added additional band combinations designed specifically for WorldView-2. For an in-depth 
look at the benefits of the Eight Spectral Bands of WorldView-2 please visit 
http://www.digitalglobe.com/downloads/white-papers/DG-8SPECTRAL-WP.pdf  
 

1.  From the ERDAS IMAGINE 2011 main menu bar click on File > Open > Raster Layers 
and navigate to the folder that contains your WorldView-2 image. 

 
Note: Multispectral Imagery from DigitalGlobe resides in a subdirectory with a _MUL in the 
folder name (e.g. 05225877010_01_P001_MUL) 

 
Fig.7. Band Groups (WorldView -2)   

 
 

http://www.digitalglobe.com/downloads/white-papers/DG-8SPECTRAL-WP.pdf


  
 
 
 
  

 

2. From the ERDAS IMAGINE 2011 main menu bar click on the Multispectral tab and 
change the sensor to WorldView-2 in the Bands group. From the drop down list you can 
easily switch between pre-defined band combinations for WorldView-2 (See Fig.7).The 
document http://www.digitalglobe.com/downloads/white-papers/DG-8SPECTRAL-WP.pdf 
provides great insight into what each band may be suitable for in different multispectral 
analysis applications 

 
  

Hyperspherical Color Space (HCS) Pan Sharpening 

Pan-sharpening is a technique that merges high-resolution panchromatic data with medium-
resolution multispectral data to create a multispectral image with higher-resolution features. 
Hyperspherical Color Space Pan Sharpening was designed specifically with WorldView-2 in 
mind and is a new feature in IMAGINE 2011. However, HCS works with any multispectral data 
containing 3 bands or more. For more information on HCS please visit 
http://www.digitalglobe.com/downloads/WorldView-2_Pan-Sharpening.pdf 

 

1. To Pan-Sharpen using the HCS technique click on the Raster Tab, and select the Pan 
Sharpen pull down and select HCS Resolution Merge 

 

 

 
 

                    Fig.8.HCS Resolution Merge  

 

 

 

 

http://www.digitalglobe.com/downloads/white-papers/DG-8SPECTRAL-WP.pdf
http://www.digitalglobe.com/downloads/WorldView-2_Pan-Sharpening.pdf


  
 
 
 
  

 

 

 

 
To pan sharpen DigitalGlobe imagery you will need both the multispectral image files as well as 
the panchromatic image files. WorldView-2 bundle products contain both of these file sets.  
 
The input multispectral and panchromatic images can be found in a sub directory with 
multispectral (_MUL in folder name) and panchromatic (_Pan in folder name) images living in 
their respective folders.  
 

2. Navigate to the folder with the Pan file and select it for the High Resolution Input (Pan) 
File (This can be GeoTiff, NITF, or IMG) 

3. Navigate to the folder with the Multispectral file and select it for the Multispectral Input 
File (This can be GeoTiff, NITF, or IMG) 

4. For the Output File navigate to a folder where you would like the pansharpen file to 
reside. Name this file. It will be given a .img extension 

 

 

 
Fig.9. Hyperspherical Color Space Resolution Merge 



  
 
 
 
  

 

 

 
5. Under the output dropdown you’ll see a check box with “Stretch to Unsigned 8bit” This 

function will apply a minimum maximum stretch range from 0-255 to the image. Min-max 
function makes the range of the lookup table vary linearly from the minimum statistics 
value to the maximum statistics value in the input (X) direction and from 0 to the 
maximum brightness value in the output (Y) direction. For this example weôll leave this 
unchecked. 

 
6. For Process Area we’ll leave intersection as the input since it will automatically use the 

intersection of the Pan and Multi image 
 

7. For Resampling we’ll select Bilinear Interpolation.  
 

Which technique is best will largely depend on the relative spatial resolutions of the data being 
merged. Any use of the Nearest Neighbor option will likely result in edge effects still being 
visible in the merged data at the interval of the original multispectral pixel sampling; however, it 
is the fastest technique to use. If the ratio of high resolution to low resolution is 2:1 (for example, 
Landsat 15 m Pan to Landsat 30 m multispectral), then Bilinear Interpolation is a reasonable 
compromise of image quality and speed of processing. For pixel ratios of 4:1 or higher (for 
example, QuickBird 60 cm Pan to QuickBird 2.4 m multispectral), the 4x4 sampling window 
used by cubic convolution may provide the better results. 
 
However, in some cases, Cubic Convolution has proved to generate worse results than 
Bilinear Interpolation. We recommend that Bilinear Interpolation be used whenever the 
merge is performed on large files that will take a considerable amount of time. For smaller 
merges that can be performed quickly, you may wish to try both Cubic Convolution and 
Bilinear Interpolation, and choose the result based on visual inspection of the output of each 
resampling technique. 
 

8. The default for smoothing filter is 7. Weôll use this value for this process. Smoothing 
Filter defines the size in pixels of the filter used to smooth the output image. This option 
uses a square window filter surrounding the pixel of interest, therefore enter an odd 
number. The default setting is 7x7. Smoothing softens the transition between the 
images. 

 

 

 

 

 

 

 

 

 

 

 



  
 
 
 
  

 

 

9. When the process has finished, go to the Home tab, select the Add Views menu and 
select Display Three Views. 

 
10. Go back to the Add Views menu and select Vertical Layout.  

 

 
 
Fig.10. Add Views menu 

 

 
11. Open your Multispectral.img in View #1 

 
12. Open your panchromatic.img in View # 2 

 
13. Open your HCS.img in View # 3 

 
 



  
 
 
 
  

 

 

Use some of the tools shown below to link all of the views and roam around the images to see 
the new .5 meter 8 band image. 

 
 

 

14. You can also use the tools at the top right of each viewer  to link / unlink and 
sync the different viewers. 

 

 
Fig.11. Example of Multispectral, Panchromatic, and HCS Pansharpened Image 

 

 

 

 

 

 

 

 

 

 



  
 
 
 
  

 

 

Discriminant Function Change Detection 

DigitalGlobe’s vast archive of satellite imagery (well over a billion square kilometers) is perfectly 
suited as a historical account of change on the earth. For a trained imagery analyst the process 
of detecting change from one image date to another may be an easy task. However this is not 
always economically feasible. ERDAS IMAGINE software employs algorithms to extract 
information from satellite imagery in an automated fashion.  For the IMAGINE 2011 release, 
ERDAS, Inc. has developed a new algorithm for change detection between two co-registered 
images acquired at different dates. This algorithm, named Discriminant Function Change 
(DFC), characterizes the natural distribution of spectral clusters in one image’s data space and 
then uses a discriminant function to measure probability of change of the pixels in the other 
image. WorldView-2 is well suited for this application because of its ability to collect more of the 
visible spectrum with its 8 band technology.  
 
For more technical information on DFC please visit 
http://www.erdas.com/Resources/whitepapers 
And search for ñDiscriminant Function Change in ERDAS IMAGINEò 
 
 
 

1. To begin the Discriminant Function Change Detection application click on the Raster tab 
and select Discriminant Function Change  

 

 
Fig.12. Discriminant Function Change Menu 

 

 

Note: You will need at least two images from different dates over the same location in order to 
run the DFC algorithm. For this example we use two images; one from the QuickBird Satellite 
taken on the 6th of January and one from the WorldView-2 Satellite taken on the 10th of June. 
 

2. Select 06jan_qbsubset2.img as the Input Before Image and 10jun_wv2_subset.img 
as the Input After Image as seen below. 

 

http://www.erdas.com/Resources/whitepapers


  
 
 
 
  

 

 
                      Fig.13. Discriminant Function Change Detection  

 

 

3. Check the boxes for Positive Change, Negative Change and Combined Change and 
name the output file accordingly as seen in the figure above.  

 
4. Click OK to run the process.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 



  
 
 
 
  

 

5. When the process is completed, open the before, after and combined.img files in the 
same viewer. Make sure the combined.img is the top layer and is active, then select 
Panchromatic tab.  
 

6. Select the General Contrast drop down menu and click Load Breakpoints 
 

 

Fig.14.Load Breakpoints  



  
 
 
 
  

 

7. Select the combined_break.mbp file and click OK 
 

 

 
Fig.15. Select BreakPoints File 

 

 

 
This filters the points in the viewer, so that only points with > 90% probability of change appear. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



  
 
 
 
  

 

 

8. Fit the image to frame using the  on the Home tab. Take note of some of the 
areas of significant change (white areas) and zoom to those areas to investigate further. 
You can use the Swipe / Blend / Fade Tools or you can use the check boxes in the table 
of contents to turn layers on or off. 

 

 
Fig.16. Discriminant Function Change Detection Image 

 

 

 

 

 

 

For more information on ERDAS IMAGINE go to 
http://erdas.com/service/support/ERDASSupport.aspx 
 
For more technical information on DigitalGlobe Products and Services please visit 
http://www.digitalglobe.com/resources 
Additional Documents and Imagery Product Samples may be downloaded from here. 
. 

http://erdas.com/service/support/ERDASSupport.aspx
http://www.digitalglobe.com/resources

