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Supervised Classification w orkflow in ENVI 4.8
using WorldView -2 imagery

WorldView-2 is the first commercial high-resolution satellite to provide eight spectral sensors

in the visible to near-infrared range. Each sensor is narrowly focused on a particular range

of the electromagnetic spectrum that is sensitive to a particular feature on the ground or a

property of the atmosphere. Together they are designed to improve the segmentation and

classification of land and aquatic features beyond any other space-based remote sensing

platform. Figure.l illustrates the bands of DigitalGlobe 6 s sat el |l ite constellatio
they fall in the visible spectrum (units are in nanometers). |1t 6s i mportant to note
additional bands provide more coverage over the spectrum thus providing more information.

The increased spectral fidelity of WorldView-2, combined with very high spatial resolution, will
provide the additional data necessary to address the feature classification challenge. For
example, when looking at land classes, WorldView-2 is expected to deliver a 10-30%
improvement in accuracy compared with traditional VNIR imagery overall.

More information of the benefits of the eight spectral bands of WorldView-2 can be found at
http://www.digitalglobe.com/downloads/white-papers/DG-8SPECTRAL-WP.pdf

QuickBird
Panchromatic |
Multispectral I . L]

WorldView-1
Panchromatic "

WorldView-2

Panchromatic |
Multispectral B N N ——
I
400 500 600 700 800 900 1000
Fig.1. Spectral Bands of Digital Gl obeds Satellites

Supervised classification can be used to cluster pixels in a dataset into classes corresponding to
user defined training classes. This classification type requires that you select training areas for
use as the basis for classification. Various comparison methods are then used to determine if a
specific pixel qualifies as a class member. ENVI provides a broad range of different
classification methods.



http://www.digitalglobe.com/downloads/white-papers/DG-8SPECTRAL-WP.pdf
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In this tutorial, you will experiment with selecting training areas, also known as regions of
interest (ROIs) using a DigitalGlobe WorldView-2 8 band multispectral image.

Opening the WorldView2 image

1. Goto File > Open External File>WorldView>GeoTiff.
Note: If you have image files with the .RPB file in the metadata, particulary Level 1B image and
ORZ2A, you can load the image using the RPC file. Open with RPC positioning. You can also
open a Mosaic Tiled WorldView Product as well as GeoTiff and NITF using the Rigorous Sensor
Model.

For this exercise wedl]l |l oad the GeoTiff directly

O ENVI48 E=REeR >

[File] Basic Tools _Classification _Transform _Filter _Spectral Map Vector Topographic Radar Window Help |

Open Image File

Open Vector File Landsat 4
Open Remote File SPOT >
Open External File > KONOS %
Open Previous File » QuickBird <
WorldView > GeoTIFF
Launch ENVI Zoom OrbView-3 5 NITF
Edit ENVI Header GeoEye-1 » Open with RPC Positioning
IRS 4 Mosaic Tiled WorldView Product
Generate Test Data
I AVHRR |

Fig.2. Openina WorldView Imagery
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. » Computer » test_drive (F:) » Fourmile » 052582771010 01 » 052582771010_01_P001_MUL v Search 052582771010 01 POOL.. O

Organize v New folder =~ 0 @

7

Name Type Size Tags

-

¢ Favorites
Bl Desktop |@J 10SEP12175937-M2AS-052582771010_01_P001.TIF 9/16/2011 4:53 AM TIFF image 597,972 KB
8 Downloads

UET
"= Recent Places

= Libraries
Eej Documents
J Music
|| Pictures
Videos

1% Computer

& Local Disk (C:)
a Local Disk (D:)
a test_drive (F:)
L moberg (\\cofsl"
3% users (\\cofsl) (R_
L% fsl (\cofsl) (S:)
L% PM (\\cofs1\fsl\

...... M rnfe) (7 T

File name: 10SEP12175937-M2AS-052582771010_01_P0O01.TIF

Fig.3. Select Image

2. Select the image file you would |Iike te classi
M2AS-052582771010_01_PO001.TIF and click Open.

Not e: Digital Gl obe multispectral products wil!/l h a
name 10SEP12175937-M2AS-052582 771010 _01 POO1.TIF contains Al
multispectral and 2AS describes the product level. In this case we are using an Ortho Ready

Standard product or Level 2A.
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The Available Bands List window will appear. Notice all 8 multispectral bands are present. In
this case wedll | oad B&mmhg. 8, 3 and 2 from our WV

File Options
10SEP12175937-M2AS-052582771010_01_P
Band 1
Band 2
Band 3
Band 4
Band 5
Band 6
Band 7

Map Info

foooooooao

< | 1]

(7) Gray Scale @ RGB Color

@R Band 8:10SEP12175937-M2AS-05

@G  Band 3:10SEP12175337-M2A5-05

@B  Band 210SEP12175937-M2AS-05

Dims 6636 x 5749 (Unsigned Int) [BSQ]

Load RGB | No Display |

Fig.4. Available Bands List

3. Select RGB color and click on Band 8 (it will load into the Red Gun), click on Band 3 (it
will load into the Green Gun) and click on Band 2 (it will load into the Blue Gun). Then
click on Load RGB. This will load a false color combination using WorldView-2 6 s -2NI R
Band in combination with the Green and Blue band.

Note: The Band numbers in the Available Bands List correlate with the bands of WorldView-2 as
follows: Band 1 = Coastal Blue; Band 2 = Blue; Band 3 = Green; Band 4 = Yellow; Band 5 =
Red; Band 6 = Red Edge; Band 7= Near Infrared 1; Band 8 = Near Infrared 2. You can load any

type of band combination here. This is where you can begin to explore the different band
combinations of WorldView-2
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Once loaded, the image will open in three views; a main window, a scroll window and a zoom
window.

5 #1 (R:Band 8,G:Band 3, | 2):10SEP12175937-M: 1010_01_POOL.TIF
File Overlay Enhance Tools Window

R ]

) »

Fig.. View Window, Scroll Window and Zoom Window
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You can pan around the image using the scroll window and the main windows by clicking with
the left mouse. You can also view the spectral signatures of pixels within the image by using the
Z profile tool. To view the spectral signatures complete the following:

4. From the Display group menu bar, select Tools > Profiles > Z Profile (Spectrum) to
begin extracting spectral profiles.

5. Examine the spectra for areas that you previewed above using color images and the
Cursor/Location Value dialog by clicking the left mouse button in any of the display
group

O ENVI48 -— T EETRTE

[File Basic Tools Classification Transform Filter Spectral Map Vector Topographic Radar Window Help l

™

£y #1 (R:Band 7,G:Band 3,B:Band 2):10SEP12175937-M2AS-052582771010_01_POOL.TIF ‘E B x|

File Overlay Enhance Tools Window

Edit Options Plot_Function Help

File

Spectral Profile

File Options

10SEP12175937-M2AS-052582771010_01_P
o Band 1

Band 2
Band 3
Band 4
Band 5
Band 6 I
Band 7
o Band 8
#8 Map Info

=]
=]
=]
=]
o
o

< [ 10 | 3

- (") Gray Scale @ RGB Color

@R Band 7:10SEP12175937-M2AS-05
©)G Band 3:10SEP12175937-M2AS-05

g  Band 210SEP12175337-M2AS-05.

Fig.6. Spctral Plot
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Note the relations between image color and spectral shape. Pay attention to the location of the
image bands in the spectral profile, marked by the red, green, and blue bars in the plot.

6. From the Spectral Profile dialog menu bar, select File > Cancel.
Region of Interest Tool
The next step in supervised classification is capturing your regions of interest. These will be the
training samples. The classifier will use the spectral signature of the pixels within your region of

interest to perform classification.

) #1 (R:Band 8,

e

File Overlay Enhance | Tools | Window
DS Link
Profiles
Polarization Signatures o e P
Region Of Interest ROI Tool...

Cdi Mapping Restore Saved ROI File

Cursor Location/Value... Save ROIs to File
Pixel Locator... Delete ROL...
Point Collection...
Build Mask...

Measurement Tool...

Export ROIs to EVF...
Export ROIs to n-D Visualizer

Output ROIs to ASCIL..
Line of Sight Calculator...
Reconcile ROL...

Spatial Pixet Edor... Reconcile ROIs via map...

Spectral Pixel Editor...
Ao Band Threshold to ROL..

2D Scatter Plots... Create Class Image from ROIs...

Create Buffer Zone from ROIs...
3D SurfaceView...

Compute ROI Separabilty

7. In the Main View window select Tools > Region of Interest >ROI Tool
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File ROLType Options Help

Window: @ Image () Scroll () Zoom (") Off

ROI Name Color | Pixels | Polyad
Region #1 Red 0 00 A

™
[NewRegon] ’GotoHDeletePan‘

[Stats HGrow l Pixel l[_Delete ROI]

[ Select All ||| [ Hide ROIs | | Show ROIs |

Fig.8.ROI Tool

Begin to select regions of interest either in the Image, Scroll or Zoom windows. Note: Use the
zoom window for better detail when collecting ROIs.

8. At the top of the ROI Tool select the Zoom button.
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You can begin collecting classes from your image. Capture at least 3 ROIs within a certain class
for the best representation of the spectral signature within that class.

File ROLType Options Help

Window: ) Image () Scroll @ Zoom () Off

ROIName | Color | Pixels
Region #1 Red 831 1/831 -

<l

| (New Regin ] [ Goto | [Delete Pat ||

(St ) [Grow ] [Pol ) (Dete RO |

| | Select Al | “ [ Hide ROIs || Show ROIs |

Fig.9. Collecting Regions of Interest

9. Left click within the zoom window to begin drawing your polygon. Two right clicks of the
mouse will close the polygon. Scroll throughout the image and collect the different areas
of the same class. In this example we start collecting vegetation. For this exercise we
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will clump healthy vegetation into one class as we are trying to pull out the healthy areas
from the burn area in the image.

File Window

Overlay Enhance Tools

o

b || |

oL

(3 #1801 Too |

File ROLType Options Help

|| Window: ) Image () Scroll @) Zoom () Off

ROIName | Color | Pixels | Polyad
Healthy Green 1,395 3/1.39¢ &
- |Bum |Black 158 17158 [
™ »

l[NewRegaon]H[Goto][De:aePan]l

I[StatsHGmw][Pb(eI“DeleteROl]l

, | Select Al | ” [ Hide ROIs || Show ROIs |

ig.lO. Colltlg Multiple ROI and classes

10. Once you have collected at least 3 ROIs of the first class click on New Region in the
ROl Tool and start collecting another cl
burned area in the image. We will collect at least 3 areas.

ass.
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Note: Because we used a False Color band combination we can see the burn areas really stand
out as grey/black in the image.

We repeat the steps for collection of additional
classes in the image; Healthy Vegetation, Burn, Roads, Water, Man Made, and Soil. Change

the color of your ROI by right clicking on the color in the color column in the ROI tool and

selecting an appropriate color.

File ROLType Options Help

Window: () Image (7) Scroll @) Zoom

ROIName | Color | Pixels | Polygons |
Healthy VegetaticGreen 1714  |5/1.714 |
Bum Back  |29%  529% [
Roads Yellow 586 17/586 ‘
Water |Blue 2481 13/2,481
Man Made APurprle ;785 7 5/785
‘B Red 1358  6/1358

< [
| New Region ||| Goto || Delete Part |

| Stats | Grow | | Pocel | Delete RO |

[ Select Al ||| [ Hide ROIs | | Show ROIs |

i

| —

Fig.11. Example ROI classes
Once you are satisfied withthec | asses youbdve cololsaethissROIfigtmu wi | | n

perform your classification.

11. To save click on File > Save ROIs to File. Select all the classes you want used in the
Supervised Classification and then Choose where you want to put the .roi file.
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File ROI_Tpe 7 Options

i & SaveROIstoFile . o

Select Regions to Save:

Healthy Vegetation (6636x5749) [Green] 1714 points
Bum (6636x57439) [Black] 2996 points

Roads (6636x5749) [Yellow] 586 points

Water (6636x5749) [Blue] 2481 points

Man Made (6636x5749) [Pu 785 poi

< | "

Number of items selected: 5

| Select All kems || Clear Al tems |

Enter Output Filename [roi] | Choose |

Fig.12. Save ROls to File

12. In the Enter Ouput Filename [.roi] window navigate to where you want the file saved
and give it a name.
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Organize v

New folder

Bzl Compuie s i roumier o [ ome ]

7T Favorites
Bl Desktop
8 Downloads

o
"= Recent Places

) Libraries
[3 Documents
J Music
[=| Pictures
B videos

1M Computer
&, Local Disk (C:)
a Local Disk (D:)
a test_drive (F:)
L% moberg (\\cofsl’

% users (\\cofsl) R

3% fs1 (\cofsl) (52)
3% PM (\\cofs1\fs\

il ueare N\ rnfel) (7.7

(LM ourmile Classes.roi

Fi3. SaveRI to folder

13.1 n t

Name

. 052582771010_01
£ classification.img
Ll classification.rrd
# distanceimg

L] distance.rrd

‘ fourmile.aoi

# fourmileimg

|| fourmile.roi

|_| fourmile.rrd

# fourmile2.img
L‘ fourmile2.rrd

L] Reflectance

|| Reflectance.hdr
1_7 result

|| resulthdr

|| rule_image

|| rule_image.hdr
|| signatures.sig

ol i i

Date modified

1/21/20121:52 PM
1/21/2012 2:23 PM
1/21/2012 2:23 PM
1/20/2012 3:43 PM
1/20/2012 3:43 PM
1/20/2012 3:29 PM
1/20/2012 2:49 PM
9/15/2011 4:22 PM
1/20/2012 2:49 PM
1/20/2012 2:52 PM
1/20/2012 2:52 PM
9/15/2011 4:15 PM
9/15/2011 4:15 PM
9/15/2011 4:29 PM
9/15/2011 4:29 PM
9/15/2011 4:29 PM
9/15/2011 4:29 PM
1/21/2012 2:22 PM

1909017 2,96 DA A

Type
File folder

ERDAS IMAGINE d...

RRD File

ERDAS IMAGINE d...

RRD File

ERDAS IMAGINE d...
ERDAS IMAGINE d...

ROI File
RRD File

ERDAS IMAGINE d...

RRD File
File
HDR File
File
HDR File
File
HDR File
SIG File

CONAC TAAARTAIC

11,106 KB
5,196 KB
16,397 KB
4362 KB
15KB
18,695 KB
1KB

6,226 KB
8,029 KB
3121 KB
506,100 KB
2KB
37,257 KB
2KB
506,100 KB
1KB

176 KB

S GA1 VD

his e

webdbve call

xampl e

Fa) SaveROIsto File = o

Select Regions to Save:

Healthy Vegetation (6636x5749) [Green] 1714 poirt
Bum (6636x5749) [Black] 2996 points
Roads (6636x5749) [Yellow] 586 points

| Select All tems || Clear Al kems |

Enter Output Filename [roi]

F:\Fourmile\Fourmile_Classes roi

Fig.14. Save ROIs to File
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14. Then click Ok

Supervised Classification

We 61 | now apply the ROI file that we created to t
15. To open Supervised Classification Go to Main ENVI tool bar > select Classification >
Supervised > Maximum Likelihood. I n t his case wedll use the |
method

Maximum likelihood classification assumes that the statistics for each class in each band are
normally distributed and calculates the probability that a given pixel belongs to a specific class.
Unless a probability threshold is selected, all pixels are classified. Each pixel is assigned to the
class that has the highest probability (i.e., the maximum likelihood).

File Basic Tools | Classification | Transform Filter Spectral Map Vector Topographic Radar

Supervised > Parallelepiped
Unsupervised 4 Minimum Distance
Decision Tree 4 Mahalanobis Distance
Endmember Collection Maximum Likelihood
Create Class Image from ROIs Spectral Angle Mapper

Post Classification Spectral Information Divergence

Binary Encoding

Neural Net

Support Vector Machine

Fg.15. Classiflcatlo
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16.TheCl assi ficati

on
WV-2 image we collected our ROIs in. Selectthati ma g e .

menu wi | |
We ol |

I nput Fil e appear .
keep all th

not select Mask Band. You can use this function to leave out certain bands when

performing classification.

Select Input File:
10SEP12175937-M2AS-052582771010 01 PDO1.

) ™

File Information:

File: F:\Fourmile\052582771010_01\05258277101(
Dims: 6636 x 5749 x 8 [BSQ]
Size: [Unsigned Int] 612,322,455 bytes.
File Type : TIFF
Sensor Type: Unknown
Byte Order : Host (Intel)
Projection : UTM, Zone 13 North
Pixel :2 Meters
Datum :WGS-84
Wavelength : None
Upper Left Comer: 1.1
Description: GEO-TIFF File Imported
into ENVI [Sun Jan 22 12:50:02
2012]

Spatial Subset | Full Scene

|SpectraISubset | 8/8 Bands

| Select Mask Band | <None Selected>

| OK ||Cancl |

l Previous }

E.I

ig.16. Classification Input File

We 61 | now open our

17. Click on Open at the bottom.

ROI file created to ru

t hat

we
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File Information:

File: F:\Fourmile\052582771010_01\05258277101(
Dims: 6636 x 5749 x 8 [BSQ]
Size: [Unsigned Int] 612,322 459 bytes.
File Type : TIFF
Sensor Type: Unknown
Byte Order : Host (Intel)
Projection : UTM, Zone 13 North
Pixel :2 Meters
Datum :WGS-84
Wavelength : None
Upper Left Comer: 1,1
Description: GEQO-TIFF File Imported
into ENVI [Sun Jan 22 12:50:02
2012}

< |,

Spatial Subset | Full Scene

o/8Boncs

| Select Mask Band | <None Selected>

‘ Previous [ QIH|V|

Previous File

New File...

Spectral Library...
s ; 5w ROIFile...
B ;ﬁ B> EVFFike.
Fig.17. Select ROI file for Classification

18. Scroll down to ROI File and left click with your mouse.
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' Enter ROI Filenames

, y» » Computer » test_drive (F:) » Fourmile » v | 49 ||| Search Fourmite pel
DA =

Organize v New folder

% Favorites Name Date modified Type
Bl Desktop 1, 052582771010_01 1/21/20121:52PM  File folder
& Downloads U fourmile.roi 9/15/20114:22PM  ROIFile

‘%] Recent Places l __ Fourmile_Classes.roi 1/22/20122:11 PM  ROIFile

- Libraries
E-j Documents
J Music
|| Pictures
- Videos

1 Computer

&, Local Disk (C:)
= Local Disk (D:)
a test_drive (F:)
% moberg (\\cofsl’
% users (\\cofsl) RE|
% fsl (\cofsl) (S:)
3% PM (\cofsl\fsl\
il ueare A\ rafel) (7.

File name: Fourmile_Classes.roi

Fig.18. Select ROI file

19. Navigate to your ROI file and select it and click Open
A message will appear which states that your regions are restored (Fig.19).

ENMesase

@ ROI File: F:\Fourmile\Fourmile_Classes.roi

The following regions were restored:

Healthy Vegetation (6636x5749) [Green] 1714 points
Burn (6636x5749) [Black] 2996 points
H Roads (6636x5749) [Yellow] 586 points
Water (6636x5749) [Blue] 2481 points
Man Made (6636x5749) [Purple] 785 points

|l

Fig.19. Classes Restored
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Select Input File: File Information:

File: F:\Fourmile\052582771010_01\05258277101(
Dims: 6636 x 5749 x 8 [BSQ]
Size: [Unsigned Int] 612,322 453 bytes.
File Type : TIFF
Sensor Type: Unknown
Byte Order : Host (Intel)
Projection : UTM, Zone 13 North
Pixel :2 Meters
Datum :WGS-84
Wavelength : None
Upper Left Comer: 1,1
Description: GEO-TIFF File Imported
into ENVI [Sun Jan 22 12:50:02
2012]

< | i

Speca Sueet ] 88 Bonds

[ Select Mask Band | <None Selected>

| Previous ] q:mvl

20. Click OK to accept
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Youdl | now set up your Par g9eeRige2l)s f or Maxi mum Lik

21. Select the classes you want to use in the classification in the select classes from
Re gi o n sSet PWbdbility Thresholdtonone.We 61 I output to a file
classification image. Click on Choose and navigate to the folder you want to store the
file in. Give it a name. Here we call it Fourmile_Classification. We will also output a
rule image and call it Fourmile_rule. Click on OK to run. The status window will appear
(See Fig.22)

Output Resultto @) File ) Memory

Healthy Vegetation [Green] 1714 points
Bum [Black] 2996 points

Roads [Yellow] 586 points Bt Br
Water [Blue] 2481 points er Output Class Filename | Choose

Healthy Vegetation [Green] 1714 poirts F:\Foummile\Fourmile _Classffication

Bum [Black] 2556 points

Roads [Yellow] 586 points e
Water [Blue] 2481 points Output Rule Images ? Yes  §t
Man Made [Purple] 785 points

Output Resultto @) File () Memory

Enter Output Rule Filename

F:\Fourmile\Fourmile_rule

Number of items selected: 5

| Select All ftems || Clear Al kems |

Set Probability Threshold

@ None (7 Single Value () Multiple Values

Data Scale Factor 1.00

| OK_ || Queue || Cancel || Help |

Fig.21. Maximum Likelihood Parameters
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Input File : F:\Fourmile\052582771010_01\05258277101 0_01_P1D
Qutput File: F:\Fourmile\Fourmile_Classffication :

| »

| 1%

Fig.22. Classifier status window

Once the classification is complete a new classification image will appear in the Available bands
list.

22. Click on the Classification image. In this case, Fourmile_Classification (Max Like file)
and click Load Band at the bottom.

O Available Bands List euiE s

File Options

Fourmile_Classffication - .I
o Max Like (10SEP12175937-M2AS-052
&8 Map Info
Fourmile_rule
O Rule (Healthy Vegetation [Green] 1714| _
Rule (Bum [Black] 2996 points) 7
Rule (Roads [Yellow] 586 points)
Rule (Water [Blue] 2481 points)
Rule (Man Made [Pumple] 785 points)
Rule (Soil [Red] 1358 points)
&8 Map Info -

« »
@) Gray Scale () RGB Color

=
O o0ooao

Selected Band
Max Like (10SEP12175937-M2AS-05258277

Dims 6636 x 5749 (Byte) [BSQ]

LoadBandIlhhm'

Fig.23. Available Bands List
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Your Classification image will then load into the viewer.

Fig.24. Example of Classification Image




